Is the Equisense Motion compatible with all devices?

Updated 2 months ago by Sina

The Equisense Motion is compatible with iOS 12 and newer, iPhone 5s and newer, as well as Android 4.3 and newer.

Your android device has to be compatible with Bluetooth 4.0+ technology (4.0, 4.1, 4.2 ...). Use the BLE Checker to check the Bluetooth compatibility of your Android device. If you are not sure, if you have the right Bluetooth technology, don't worry. If the Equisense App appears in your Google Play Store or App Store, it means that you have the right version.

The following smartphones are blacklisted:
- Samsung Galaxy J3 2016
- Huawei P8 Lite 2015
- Huawei P9 Lite
-
Samsung Galaxy A5 2016
- Samsung Galaxy A3 2016
- HiSense L830

You are responsible for any errors that occur when using an Equisense Motion with any of these smartphones.


How Did We Do?


Powered by HelpDocs (opens in a new tab)

Powered by HelpDocs (opens in a new tab)